[DONE] Ideas not synchronised across devices?

Looks like ideas are not synchronised across devices.

Here is what I see on iPadOS:

An here is x3Note on Mac:

(Yes, I have tried to press 'Reload button!) :wink:

It syncs, might be empty for networking delay, could you wait a little and check again.

Hmmm… Something wrong here. Ideas are not synced.

Here is what I see on my Mac:

No folder with attachments? Where are Ideas stored?
Relaunched x3Note several times and restarted all the devices - no changes: Ideas are not synced and there is no attachments folder.

Attachments folder is hidden in iCloud folder, and if you can see the ideas from macOS version, that means the file is there, are those devices using the same apple account?

Got it! Definitely a bug.
When I change the Store location to ‘On device’ the attachments folder appears here /Users/valerykondakoff/Library/Containers/com.wod.x3note/Data/Documents/attachments. But if I change the Store location back to ‘On iCloud’ the attachments folder does not appears on iCloud. That’s the reason it is not synced.
See the video.

Infact, those folders in local and in iCloud folder, the structure is different.

On local, those three folders (files, attachments, keyValueStores) are at the same level, but on iCloud folder, in order to hide the last two, they are actually stored outside the files’ parent folder (that’s how to make the files syncable but invisible to user)

When you change the store location from ‘iCloud’ to ‘On Device’, it actually move those folders from iCloud folder to the local folder, and if you see those folders, which means they are actually there in the iCloud folder, otherwise you can’t see them on your local folder.

I think there’s some other problem here, not sure if it’s because the Big Sur is in beta? because on my end, my 3 platforms are syncing.

Ok… I think this issue worth some investigation…
This is not Big Sur issue, because I was able to see the attachments folder on iCloud yesterday morning (before updating to x3Note 1.2).
Now I see this folder using ‘Find any file app’:


I can see it in Terminal:

But it is completely invisible in Finder (with Show hidden files enabled).
Do you have a link to x3Note 1.1? I’m sure I was able to see attachments folder in Finder and the sync was successful. Any chance something was changed in v1.2 and the new hidden attribute is somehow incompatible?

I noticed there’s one folder missing, called ‘keyValueStore’, the capture list is stored there, which is quite strange, if that fold is not there, you should not seeing any idea.

Could u switch to ‘On Device’ to check the folders again?

No ‘keyValueStore’ folder:

I just reinstalled x3Note to be sure. Still no ‘keyValueStore’ folder.

Might be some serious issue if the this folder get removed some how, well, reinstall won’t do anything in this case, because the fold is managed by iCloud, if on one device it is removed, all device will be removed, only add new content will create it.

I will dig into this problem, thanks very much for letting me know.

Thanks! I just added a document, but ‘keyValueStore’ folder did not appear (On Device):

try adding a new capture, or change the settings

Done. No ‘keyValueStore’ folder:

Now it’s getting wired, the ides has data, means ‘keyValueStore’ has contents in it, where’s the only place to hold those information.

The folder is correct, your new doc is showing there.

:thinking:

I guess the new ides is not showing up on iPad right? if you turn on iCloud

Yes. Right now the store location is set to ‘On Device’, but if I change it to ‘iCloud’ Ideas still do not appear on iPhone/iPad.

Thanks man, I’ll install Big Sur and try to reproduce it.

I don’t think this is Big Sur-related: my first installation of x3Note was on the same Big Sur build I’m using right now (and the synchronization was working well). Don’t you want me to try to reinstall the x3Note 1.1?

I would love to send u the old version if I could. There’s just not easy way (that I know of) to distribute the 1.1 release, no testflight for mac, and adhoc release won’t work (I’ve tried to install with different mac which is correctly signed), anyway that part was not touched in this update, so I guess I need to reproduce here on my machine.

Thanks for that anyway